error adding sql details to sharepoint list in sub site

Aug 7, 2009 at 2:25 PM
Edited Aug 7, 2009 at 2:28 PM

Whatever I try with permissions on the sharepoint list / site / collection administrator i cannot get the script to populate a list in a sub site.

 

for example

http://sharepoint.domain.local/lists/aaa - works

http://sharepoint.domain.local/sites/subsite/lists/aaa - does not work

 

i am typing in the XML 

 

<siteurl>http://intranet.domain.local</siteurl>

<webname>/</webname>

 

 

and this works... however

 

 

<siteurl>http://intranet.domain.local</siteurl>

<webname>/sites/subsite/</webname>

 

 

does not

 

Any clues as to why this is? Please message if you need any more details

 

<siteurl>http://intranet.domain.local</siteurl>

 

<webname>/</webname>

Here is my config

 

 

<?xml version="1.0" ?>
<confSPListSync>

  <site id="1">
	
	<siteurl>http://sw-sp-01.sw.nps.local</siteurl>
	<webname>/sites/experiment/</webname>
	
	<ParentSQLServer>sw-sql-01</ParentSQLServer>
	<ParentSQLDatabase>BGinfo</ParentSQLDatabase>
	
	<ParentSQLStatement>SELECT User_Name, Time_Stamp FROM BGInfoTable</ParentSQLStatement>
	
	<parentlistname></parentlistname>

	<parentlinkcolumn>User_Name</parentlinkcolumn>
	<Childlinkcolumn>User_Name</Childlinkcolumn>

	<childlistname>aaa</childlistname>
	
	<CreateNewChilds>1</CreateNewChilds>
	
	<SyncColumn id="1">
	   <ParentColumn>User_Name</ParentColumn>
	   <ChildColumn>Title</ChildColumn>
	</SyncColumn>
		
	<SyncColumn id="2">
	   <ParentColumn>Time_Stamp</ParentColumn>
	   <ChildColumn>col2</ChildColumn>
	</SyncColumn>

	   </site>

</confSPListSync>